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 1.  Introduction 

This tutorial presents in detail all the steps taken to read a CAD file of a part, perform cleanup, as 
well as some geometry simplification, in order to create a good quality shell mesh. 
 
The steps described in this tutorial include: 
 

 Read the IGES file with different tolerance settings and assess the results. 

 Cleanup geometry, close gaps, modify or create new Faces etc. 

 Optionally, repeat the previous step with the help of Automatic Cleanup functionality. 

 De-featuring, removing details such as small holes. 

 Mesh the part with a uniform mesh and an element length of 10 mm. 

 Improve the mesh by manually optimizing the shape of the Macro Areas. 

 Improve the mesh by using ANSA’s automatic functions. 

 Mesh the part with a variable size, curvature dependent mesh. 
 

 1.2.  Prerequisites 

Reading the first chapter of the ANSA for CFD Quick Start Guide.pdf document is recommended in 
order to obtain a familiarization with the ANSA interface, terminology and CFD layout. 

 1.3.  Problem description 

 

The geometry of the part is shown here 
in its final state. Note that the part 
consists of more than one Property IDs 
(PIDs), as shown in different colors. 
 
 
 
 

 1.4.  Data files 

The files of this tutorial are: one IGES file named basics.igs containing the geometry and one 

ANSA file named basics_result.ansa containing the result for reference. 
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 2.  Read the CAD file 

 

Start ANSA (e.g. by typing ansa64.sh for the 64 
bit Linux version), select the CFD option from 

the pop-up launcher so that ANSA begins with 
the default CFD layout and click OK.  

 

By default you are in the TOPO menu. 

 

 

 

In order to get familiar with the icon buttons of 
the interface, you can right click on any toolbar, 
activate the “Show labels” flag and click “Apply 
to all”. 
Now the label of each button appears below 
every icon. 
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Before reading any CAD data into ANSA you can specify some settings concerning the 
application of Topology (the connectivity of neighboring Faces), and the Resolution (the 
appearance of geometrical entities on the screen). These settings should correspond to the 
dimensions, level of detail and tolerances of the CAD file to be input. 

 

Click on the “Settings” button.  

 
In the “Translators” section of the Settings window and the 
“Topology” options group, the Perform ANSA Topology flag 

ensures that the Topology is performed during CAD file 
opening. As a result when the IGES file is read later, the 
topology process will be applied. 

For educational purposes keep the Clean Geometry flag button de-activated. In this way the 

automatic geometry cleanup step will not be performed and the cleanup will be examined and 
performed manually. 

 

Note that the automatic topology is performed 
according to the tolerance settings that are specified in 
the “Tolerances” section. Make sure to specify 
appropriate tolerance values before reading a CAD file, 
to avoid collapsed Faces (large tolerances), or gaps 
(very small tolerances). For demonstration select extra 
fine tolerance settings (HOT POINTS matching 

distance 0.003125, CONS matching distance 0.0125). 

 Also note that the appearance of geometrical details 
depends on the settings found in the “Resolution” 
section. Keep the default value of 20 for Perimeter 
Length in the CONS Resolution settings group. (Note 

that this value also corresponds to the initial 
discretization length or element length). Change the 
value in the Curves entry field to 2 in order to view 
small geometrical features in more detail. Press OK 
and then Apply in the warning window that opens. 
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Now read in the IGES data from File>Open. 
The File Manager window appears.Ensure to 
switch the filter type to IGES to be able to view 
the IGES file! 

Navigate and select the IGES file 

basics.igs. Click Open. 

! Note that when opening a CAD file (such as 

IGES) and not an ANSA file, ANSA 
automatically opens the “Settings” window in 
the “Translators” section, thus prompting the 
user to set the “Topology” as well as the 
“Tolerances” settings prior to reading the file. 

Close the “Settings” window. 

  

 
 
 

The CAD file is read and topology is applied. 
You should see the part as shown. Change the 
view of the part to better understand the 
geometry. 

Press:  

 

Ctrl + left button to rotate the part 

  

Ctrl + middle button to translate the part 

  

Ctrl + left and middle mouse button (or 
mouse wheel) to zoom in and out 

 

 

 

 
You can also zoom in and out with the F7 and F8 keys. 

 

 
If at any time the view is lost, press F9 to fit all to the screen. 

 
 

 

Notice that as by default the visibility mode of the 
model is set to ENT (Entity), you can see the red, 
yellow and cyan CONS (Curves ON Surfaces). 

  

The coloring has to do with the connectivity of the 
Faces. 

 
Red: a Single free edge CONS 

 
Yellow: a Double CONS shared by two neighboring 

connected Faces 
 
Cyan : a Triple CONS shared by three or more 

connected Faces. 
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To make things clearer, you can activate and 
deactivate the visibility of each of the three types of 
CONS separately using the “Single”, “Double” and 
“Triple” flag buttons located in the FOCUS toolbar. 

  

De-activating here the “Double” flag only the free red 
and triple cyan CONS are left visible. Apart from the 
free edges of the sheet metal there are other openings 
(gaps, untrimmed Faces etc.) that must be corrected. 

Note that the current specified Tolerances are Extra Fine and the topology process has left many 
gaps, as the CAD description is not very accurate. What if the specified Tolerances were larger? 

 

Click on the “Settings” button to open 
the “Settings” window (alternatively 
you can open the IGES file and ANSA 

will open the “Settings” window prior to reading 
the file). 
 
Click on Tolerances. 
Select middle tolerance settings (HOT POINTS 

matching distance 0.05, CONS matching 
distance 0.2) and press OK. 

 

 
Select the “Open” option from the “File” menu to 
read again the same CAD file with the middle 
Tolerance values. 

A Confirmation window opens in case you want 
to save the current database. 

Press Discard. 

 

The File Manager opens next. Select again the basics.igs file and press Open. Be careful to 

select the IGES and NOT the ANSA file! Switch the filter type to IGES in the File Manager. 

Close the “Settings” window that opens as you have already made the adjustments. 

 

The CAD file is read and Topology is applied, 
this time with middle tolerance values. 

 
The red free edges are now less, because the 
topology process resulted in the connection of 
more Faces automatically. 
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Activate back the visibility of 
“Double” CONS to view the whole 
part. 

  
 

 

 

Activate the “Shadow” view mode 
flag, located in the Drawing styles 

toolbar. 

 

 You can now view the Faces in gray and 
yellow (as you are always in ENT view mode). 
Gray color represents the positive side of the 
Faces while Yellow the negative one. 

The orientation is currently random. There is 
not a uniform Face orientation. 

 

 

Activate the 
Faces>Orient> [Visible] 
function.  

The orientation of all the visible Faces 
becomes uniform. 

 

 

In order to flip the now uniform orientation, you 
can use the Faces>Orient> [Visible] function 
once again. 

Orient 

Visible 
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 Switch to PID 
color view mode. 

You can now view 
the Faces colored according 
to their Property ID. (Note 
that the assigned colors to 
different PIDs are random 

when opening a CAD file, so you may see 
different colors). 

 

Switch back to ENT color view mode 
to proceed with the geometry 
checking and cleanup process. 

 

Save the file to your local directory under the name basics.ansa by selecting “Save as” from the 

File menu. The File Manager opens in order to specify the path and the ANSA database filename. 
Remember when you save or output in ANSA you must always type the appropriate extension for 
each file type. 

You will now proceed with Geometry checking. 

(If at any time you want to pause your work you can exit ANSA from File>Quit, and then start ANSA 
again and read the ANSA database basics.ansa from File>Open to resume work). 
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3. Checking the geometry  

 

Before you start cleaning up the geometry of the 
model it is useful to perform a number of checks 
that are incorporated in ANSA. 

ANSA can identify and isolate on the screen the 
problematic areas that require the user’s 
attention. 

Click on the “Checks” button, located in the 
“Tools” toolbar on the top of the screen and 
select “Geometry”. 

 

 
 

The Checks Manager window opens. Here you 
can select the type of problems that may exist in 
the geometry of the model to be investigated by 
activating the corresponding flag in the lower 
part of the window. 

Keep the default options and click Execute. 

 

 

ANSA identifies a total of 10 errors in the 
geometry of the model. 

You can highlight any of the problematic areas 
by left-clicking on it, or isolate it on the screen 
by right-clicking on it and selecting “Show only”.  

Depending on the type of the problem ANSA 
also offers the option to automatically fix it. 
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You can visualize all the errors by pressing 
Ctrl+A to select them all and then right click and 
select the “Show only” option. 

Close the Checks Manager window. 

Click “All” from the focus toolbar to make all the 
faces visible again. 

 

 

 

 

 

 

 

Click on the “Checks” button again and select 
Penetration>Intersections as shown on the left. 
This check will identify any intersecting 
geometry that needs to be corrected. 

 

Click Execute in the Checks Manager window 

that opens. 

 

ANSA identifies 4 errors. 

 

Again you can isolate them by right clicking on 
any or all of them and selecting “Show only”. 
You can select all the errors by pressing Ctrl+A. 

 

Close the Checks Manager window. 

Click “All” from the focus toolbar to make all the 
faces visible again. 

 

 

You will now proceed with the geometry cleanup 
procedure. 
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 4.  Perform Cleanup 

 

De-activate “Shadow” mode 
and the visibility flag button 
for “Double” CONS. 

  

You will now isolate a region of your part to work 
on. 

 
Activate the “Or” function located in the 
Focus Toolbar.  

 
Make a box selection of the area shown on the 
left using the left mouse button. 
 

 

The “Or” function leaves visible only the 
selected Faces. 
(If you accidentally select wrong Faces, press 
the All function of the same Group to bring all 
the entities back to visible). 
 
Activate the “Lock” flag button in the Focus 
Toolbar to lock the currently visible entities. Now 
when you press the “All” button, only the 
selected and locked entities will become visible. 

  

 

To view the complete Faces that you have left 
visible, activate again the “Double” CONS 
visibility flag. 

  

Activate also the “Cross Hatches” visibility flag.  

 

This allows the visualization of two green 
dashed lines along the center isoparametrics of 
the Faces. Apart from visualization purposes, 
the crosshatches are also used for selecting 
Faces. 
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Activate the “Shadow” mode again. 
 
Note the problem in this area. 
 

There seems to be a Face that is untrimmed 
and extends well out of the boundaries of the 
other Faces. 

 
Activate the “Not” function, of the 
Focus group, and select with the left 
mouse button this Face from its 

crosshatch. 

 

The selected Face is removed from the visible 
entities. 
 
This leaves a better view of the other Faces. 
 
You must somehow trim the big Face so that it 
matches exactly the boundaries of the other 
Faces. 

 
Press the “All” function of the Focus 
toolbar. 

 

Only the locked entities (all the entities that 
were visible at the time that you activated the 
“Lock” flag) appear. 

Notice that because we have specified a 
Resolution length of 20, some Faces appear 
coarser than their actual geometrical 
description. 

 
Activate the Auxiliaries>Fine function in TOPO 
Menu and left click on the crosshatch of the big 
Face twice. 

 

Each time you press the left mouse button the 
Resolution length of the selected Face is 
halved. This makes the Face appear with more 
detail. The curvature of the Face is now clearly 
visible. (Note that if you use the Fine function 
with the right mouse button you double the 
Resolution length of selected entities, making 
them appear coarser). 
 
! Note: Do not left click more than a couple of 

times as the resolution length will become very 
small and this will delay the “Shadow” operation. 
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Rotating the part you can see that this Face 
covers well the gap of the remaining Faces. It is 
only a matter of trimming it correctly. 

 
Activate the  
CONS>Project function. 

 
Select with the left mouse button the four red 
CONS of the Faces behind (if you cannot pick 
them, turn the view of the part around, or de-
activate Shadow mode).De-select with right 
mouse button if required. 
Confirm with the middle mouse button.  

 

Next select the Face to project and cut the 
selected CONS onto. 
 
You can pick the Face from its crosshatch or 
one of its red CONS. De-select with right mouse 
button if required. 
 
 
 
Confirm with the middle mouse button. 

 

The selected red CONS are projected on the 
Face and cut it. 
 

Press the ESC key to exit the Project 
function. 
 

 
Remember you can press the ESC key to abort 
any function if you are unsure. Additionally, after 
performing an action you can always exit the 
corresponding function by pressing the ESC 
key. 
 
 

 

 
Activate the Faces>Delete 
function. 

Select the excess Face to be deleted from its 
boundary. The Faces Delete List window 

appears.  

Press Delete to delete the Face. 

Project 
 
 

Delete 
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(! Note that to retrieve a Face, which was 

deleted unintentionally, activate the 
Faces>Undelete function, select it among the 
previewed deleted Faces and press the middle 
mouse button. Then use the Faces>Topo 
function to re-establish connectivity).  

The Face is now properly trimmed, but not 
topologically connected with the neighboring 
Faces (note the red CONS). 

Activate the Faces>Topo function. 

Make a box selection of the CONS shown on 
the left, using the left mouse button. Confirm 
with the middle mouse button. 

 

Topology is applied by ANSA according to the 
specified tolerances. 

All CONS appear yellow, indicating proper 
double connectivity. 

 
 

De-activate the “Lock” function from 
the Focus group. 

  
 
 
 

 

 
Press “All” to bring all the Faces back 
to visible. 
 
Moving to the next problematic region 

on the left. 
 
Here we have the opposite problem. A Face that 
is not large enough and a resulting gap. 

 

 
Activate the function Surfaces>Info. 
Select this Face from its crosshatch. 
 
Its Surface (its underlying CAD description) is 
also not big enough to cover the gap.  

 
Notice that the visibility 
of the Surface can be 
controlled from the 
Options window. 

Info 
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Activate the Faces>Delete 
function.  

 
 
Select the Face with the left mouse button from 
its crosshatch. 
 
! Note that when selecting a Face from its 

crosshatch, this is deleted without any warning. 
In contrast, when selecting it from its boundary 
CONS, the Faces Delete List preview window 
appears for confirmation. 
 

 

 
Notice two magenta cross Hot Points that were 
left over after the deletion of the Face. 
 

Activate the Hot Points>Delete 
function. 

 
Select with the left mouse button the two Hot 
Points as shown on the left.  

 

The Hot Points are deleted. (Although not 
necessary, you can always delete such Hot 
Points. This leaves uniform longer CONS that 
are easier to select for Face creation, and also 
results in better quality mesh later). 
 
 
 
 
Now you will create a new Face to cover this 
opening. 
 
 

 

 
Activate the Surfaces>Coons 
function. (Coons stands for the 

name of the mathematician). 
Select the four red CONS that form the 
boundaries of the Face to be created. 

 

 

 
 

Confirm with the middle mouse button. 

Delete 
 
 

Delete 
 
 

Coons 
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A preview of the Surface to be created is given 
as a cyan net. 
 
Press OK in the Coons window that appears if 

you are satisfied with the result. 

 

 

 

Upon accepting the Surface, the new Face is 
created, and is also topologically connected with 
the neighboring Faces. 
 
 

 

De-activate the “Shadow” mode 

 
 
and the “Cross Hatches” and “Double” visibility 
flags. 

 
 
Note how the problematic regions drop in 
number. 

 

Activate back the “Shadow”, “Cross Hatches” 
and “Double” flags. 
 
Move to the small triangular gap at the front of 
the part. 
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Activate the Surfaces>Info 
function. 

 
Select the Face from its crosshatch. 
 
The previewed underlying Surface appears to 
cover the gap.  
 
In this case you will create a new Face using 
the already existing Surface. 

 

 
Activate the Faces>New 
function. 

 
In the New Face Options window that appears 
select the EXISTING SURF option.  

 

Select with the left mouse button the three red 
CONS as shown on the left and confirm with the 
middle mouse button. 

 

 
 
 
 
Next select with the left mouse button the 
crosshatch of the Face whose Surface you will 
use for the new Face. 

Info 
 
 

New 
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The new Face is created. If you enquire its 
Surface with Surfaces>Info you will see that it 
uses the same one as the larger neighboring 
Face. 
  

 

Rotate the part to the other side. 
 
 
 
 
 
 
 
 
 
 
You can see that in this area there are two 
untrimmed and intersecting Faces. 

 

De-activate the “Shadow” flag from the Drawing 
styles toolbar and the “Cross Hatches” and 
“Double” flags from the Visibility status toolbar 

 
 

 
 
to have a better view of the problematic area. 
 

 
Activate the “Not” function from the 
Focus group. 
 

Select with left mouse button the two red CONS 
as shown. 
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Their Faces become not visible. 
 

 
 
Next press the “Invert” button of the 
Focus group. 

 

The visible / not visible status of all entities is 
inverted, making only the two selected Faces 
now visible.  

 

Activate the “Double” and “Cross Hatches” flags 
to view the two intersecting Faces better. 

 

 

Activate the Faces>Intersect 
function.  

 
The 
IntersectFACEs/SHELLs 
window appears. Select 
the “Union” option in the 
“Boolean Operation” 
group. 
 
Select the first Face with 
the left mouse button as 
shown and confirm with 
the middle mouse button. 

 

 
Now select the second face with the left mouse 
button and confirm with the middle mouse 
button as shown on the left. 
 
 

   

Intersect 
 
 



BASIC ANSA – Geometry Cleanup and Shell Meshing 

 

BETA CAE Systems S.A. 20 ANSA v.15.x Tutorials 
 

 

ANSA correctly identifies the excess Faces to 
be deleted and the Confirm Boolean Delete 
window opens. 

 
Click OK.  

 
 

 

ANSA deletes the selected Faces. 
 
Note that for the correct identification of the 
excess Faces to be deleted, it is important that 
the Faces have the correct orientation. Ensure 
that this is the case prior to activating the 
Faces>Intersect funtion. 
 
However a plain intersection would not suffice to 
fix this area. A fillet exists in this location 
between the neighboring Faces. 
 
 

 

 
Activate the “Shadow” flag button to 
view the intersection area better. 
 

 
 
 

 

Activate also the “Curves” visibility flag. In order 
to create the boundaries of the fillet you will use 
3D Curves. These are auxiliary curves that are 
not connected to the Faces and are used for 
CAD construction in ANSA. 3D Curves appear 
in magenta color and their visibility is controlled 
by the Curves visibility flag. 
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Now, you will create the boundaries of this fillet. 
 

Activate the Curves>Transform 
function. This function creates a  

new Curve by transforming an existing one to fit 
new start and end point positions. 
 
Select with the left mouse button the yellow 
CONS at the intersection of the two faces as 
shown. 
 
Confirm with the middle mouse button. 

 

Note the arrow that appears next. This arrow 
indicates the start of the segment. 
 
 
Select two point positions as target start and 
end for the new transformed 3D Curve to be 
created. 
 
! Note that the start and end positions should 

correspond to the direction arrow. 
 
Select the Hot Points as shown. 

 

A new 3D Curve is created, from a 
transformation of the selected one. Notice how 
this Curve follows the shape of the initial one. 
 
 
(if you accidentally picked wrong Hot Points, 
delete the unwanted new Curve, using the 
Curves>Delete function). 

 

 
While still in the Curves>Transform function, 
select again the initial yellow CONS with the left 
mouse button. 
 
 
 
 
 
 
 
 
Confirm with the middle mouse button. 

Transform 
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According to the direction of the arrow, select 
the two target start and end Hot Points as 
shown, on the other Face. 

 

Another similar 3D Curve is created. 

 

Now you will project the new 3D Curves on the 
Faces to cut them. 
 

Activate the CONS>Project 
function. 

 
 
 
 
Select the 3D Curve shown. 
 
 
Confirm with the middle mouse button. 

 

Next select the Face to project onto. 
 
You can select the Face from its crosshatch or 
boundary CONS. 
 
 
 
 
 
 
Confirm with middle mouse button. 

Project 
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The 3D Curve is projected on the selected face 
cutting it. A yellow CONS appears along the cut. 

 

While still in the CONS>Project function select 
the other 3D Curve with the left mouse button. 
 
 
 
 
 
 
Confirm with the middle mouse button. 

 

Select the Face to project onto and cut, by left 
clicking on its cross hatch. 
 
 
 
 
 
 
 
Confirm with middle mouse button. 

 

Having completed the work with the 3D Curves, 
de-activate their visibility flag button. 

  
 
 

 

Now you will delete the small excess Faces 
between the two 3D curves using the Delete 
function from the Utilities Toolbar. 
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Activate the Delete function. 
Select the two Faces with the left mouse 
button as shown on the left. Confirm 
with the middle mouse button. 

 

A Warning window appears. 

 

 

Press OK to proceed with the deletion of the 

selected Faces. 

 

 

(The advantage of the Delete function of the 
Utilities Toollbar in comparison with the 
Faces>Delete function, is the fact that you can 
select more than one Face, without being 
prompted each time for confirmation). 

 

 
Press the “All” function in the Focus 
toolbar to make all the Faces visible. 
 

 
Here you will create a curved face to close the 
fillet area. 

 

Activate the Surfaces>Coons 
function. 

 
Activate the “Loop” flag button in the Selection 
Assistant toolbar. 

 

 

Select with the left mouse button one red 
CONS. 
 

 

Coons 
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As the “Loop” flag is active, after selecting the 
first CONS, ANSA automatically identifies and 
selects the whole closed string of CONS of the 
same loop. 
 
(Use right mouse button to de-select CONS if 
required). 
 
Confirm with the middle mouse button. 

 

The Surface to be created is previewed as a 
cyan net. 

 

Press OK in the “Coons” window that appears. 

Note that in this case, in order to create this 
Face you have selected CONS that belong to 
Faces of different Property ID. (Remember that 
the flange has a different PID than the main 
body). 

 

As a result ANSA prompts you to select a PID 
for the new Face that you have created. 

The Properties window appears. 

You can double-click on one of the available 
PIDs in the list. As here you may not know 
which one is the correct PID to select, you can 
left click on another Face (crosshatch or CONS) 
from the screen. ANSA will mark the Property of 
this Face on the list so that you can middle-click 
in order to confirm it. 
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The Face is created. You can switch to PID 
display mode to check the different PIDs in 
color.  

 
(You can always change the PID of selected 
Faces using the Faces>Set PID function, by 
selecting them and pressing the middle mouse 
button. The Property list window will appear; 
select a Property and double-click or press OK). 

 
Switch back to ENT display mode. 

 

Moving now on to the next problematic area 
shown on the left. 

 
 Activate the “Or” function of the Focus 
group. 

 
Make a box selection as shown. 
 
(If you select wrongly, press “All” to bring all the 
Faces back to visible and re-select. You may 
also use the “Not” and “And” functions of the 
Focus group). 
 
 

 

You should leave visible only the round 
protrusion and the large Face shown here. 
 
Press ESC to exit the “Or” function. 
 
 
It appears that the round protrusion is not 
connected to the Face. See the red CONS all 
around. 

 

Rotate to the other side to see that the large 
Face has no corresponding opening for the 
protrusion. 
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Back to the front side, notice that again due to a 
relatively large Resolution length the protrusion 
appears quite coarse and it is hard to 
distinguish its proper shape. 
 
Activate the Auxiliaries>Fine function found in 
the TOPO Menu.  

 
Left click a couple of times on the crosshatches 
of the Faces in order to reduce the Resolution 
length. 
 

 

 
Note that if the resolution length is dropped too 
much, you may lose the shadow of the Face. To 
fix this, you can use the right mouse button to 
do the opposite, i.e. increase the Resolution 
length and make entities appear coarser. 
 
Now the geometry appears much clearer. 

 

Activate the CONS>Project 
function. 
 

Select the four red CONS around the protrusion. 

 
Note that if you activate the Feature Line flag in 
the Selection Assistant toolbar, you only need to 
select one CONS and ANSA selects the whole 
string provided the angle between two CONS is 
smaller than the specified limit. 

Confirm with middle mouse button. 

 

 
 
Next select the large Face to project the CONS 
onto. 
  
 
 
 
 
 
Confirm with middle mouse button. 

 

Project 
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The CONS are projected and cut the Face. 

 

Rotate the part to the rear side to view the 
yellow CONS along the cut that was made. 
 
Note that although the cut was made, still the 
protrusion is not connected. 

 

 
Activate the Faces>Topo 
function. 

 
Make a box selection of the CONS as shown. 
 
 
 
 
Confirm with the middle mouse button. 

 

ANSA performs topology connection. 
 
Now the boundary appears in cyan indicating 
that three Faces are connected at each CONS. 
 
Now you can delete the interior excess of the 
large Face. 
 

Activate the Faces>Delete 
function. 

 
Select the crosshatch of the inner Face as 
shown. 

  

Topo 
 
 

Delete 
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Note that as you selected from the crosshatch 
the Face was deleted without confirmation. 
 
In case of accidental deletion of a Face you can 
always use the Undo button found in the 
“Utilities” toolbar to cancel the last action 

 
 
or you can use the Faces>Undelete function. 
ANSA previews all previously deleted Faces in 
white. Select one with the left mouse button to 
retrieve it. 

 

Press “All” from the Focus group and 
rotate the part to view it from the 
outside as shown. 
 

Activate the Faces>Delete 
function and select with the left 

mouse button the crosshatch of the small round 
Face as shown. 

 

The Face is deleted without confirmation and 
the hole is opened. 

 

Activate the 
Faces>Orient>[Visible] 
function to make the 
orientation of all the 
Faces uniform. 

Delete 
 
 

 

Orient 

Visible 
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Moving now to the next area shown here in the 
circle. 

 

 

 
 
De-activate the “Shadow” flag from the Drawing 
styles toolbar and the “Cross Hatches” and 
“Double” flags from the Visibility status toolbar, 
to view the remaining gaps more easily. 
 

 
Activate the “Or” function from the 
Focus group and select with box 
selection the area shown. 

 

Activate back the “Cross Hatches” and “Double” 
flags to view the four Faces that remain visible. 
 
 
Here we have a gap that was not closed by the 
topology operation during CAD input. 
 

Point the cursor near the opening and 
zoom in real close using the F7 key. 
(The F8 can be used to zoom out). 

Note that as you zoom in closer and closer, two 
white horizontal lines appear at the bottom left 
corner of the display. 
 

 

These lines represent graphically the tolerance 
values that you have specified in the 
“Tolerances” section of the Settings window. 
These are the tolerances that are used by ANSA 
for the automatic topology operation. 

Notice that the gap here is larger than the 
tolerances (the CONS matching distance is set 
to 0.2 when the “middle” tolerance mode was 
selected). 

As a result ANSA did not connect the Faces at 
this location. You will have to connect (paste) 
these CONS manually. 
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Activate the CONS>Paste 
function. Select with the left 

mouse button the CONS as shown. 
Confirm with the middle mouse button. 
As you are exceeding the tolerances a Warning 
window appears. Press OK to confirm. 

 

 

Upon confirmation the first CONS is moved and 
pasted to the second one. 
 
Press OK in all subsequent Paste CONS 
Confirmation windows that will appear. 

 

Perform the same operation for 
the two CONS at the bottom. 

 
(What will happen to this small red CONS??) 
 
 
 
 
Select the two CONS with the left mouse button 
as shown. 
 
Confirm with the middle mouse button. 

 

Again the first CONS is pasted on the second 
one. 
As a result a white dot appears. 
This is a topological problem, as a white dot in 
the TOPO menu represents a collapsed CONS, 
that is a CONS that has its start and end points 
coincident.  
 

To fix such a problem you must 
first release all topological 
conditions at that location. 

Activate the Hot Points>Release function and 
make a box selection of the area shown.  

 

1 

2 

1 

2 

Paste 
 
 

Paste 
 
 

Release 
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All topological conditions are released. The Hot 
Points>Release function can always be used to 
correct improperly pasted CONS. 
 
As a result all CONS now appear in red, and 
five distinct Hot Points are visible. 
To be able to paste these CONS in pairs you 
must ensure that they are properly segmented. 
 

Activate the Hot Points>Delete 
function and select with the left 

mouse button the Hot point shown on the left. 

 

The Hot Point is deleted leaving one uniform 
CONS at that edge of the Faces. 
 
Now the CONS can be pasted correctly in pairs. 
 

 

Activate the CONS>Paste 
function and select the CONS as 

shown on the left. 
 
 
 
 
 
 
 
Confirm with middle mouse button. 

 

Perform the same on the 
opposite side. (Note that if you 

have not exited the function you can proceed 
with the selection of CONS without pressing the 
Paste button). 
 
Here, although you cannot distinguish them, 
there are two red CONS which are 
superimposed. 
 
 
 
Confirm with the middle mouse button. 

1 
2 

1 

2 

Paste 
 
 

Delete 
 
 

Paste 
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Now you have a gap that can be closed. 

 

Still in the Paste function select the CONS with 
the left mouse button as shown. 
 
 
 
 
Confirm with the middle mouse button. 

 

Now select the two CONS shown here. 
 
 
 
 
 
 
Confirm with middle mouse button. 

 

The problem is fixed. 
 
 
Topology is correct with yellow CONS and a 
single Hot Point at the center. 

1 
2 

1 
2 
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Press “All” from the Focus menu to 
bring all Faces back to visible. 
 
 
Press F9 to fit all to the screen. 

 

 
 
De-activate the “Cross Hatches” and “Double” 
visibility flags. 
 
 
 
Some problematic red CONS that remain are 
indicated in the picture on the left. 
 

 

Activate the “Double” visibility flag and zoom in 
close to that area. 
 
 
Some CONS are not connected. 

 

Activate the CONS>Paste 
function and select them with 

the left mouse button as shown. 
 
Remember, when you Paste CONS, the first 
CONS moves and is pasted on the second one. 
 
 
 
 
 
 
Confirm with the middle mouse button. 

 

 

1 

2 

Paste 
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Select also the two remaining CONS. 
 
 
 
 
 
 
Confirm with middle mouse button. 
 

 

The geometry here is now clean. 

 

Press F9 to fit all to the screen. 
 
 

 

 
De-activate the “Single” and  
“Double” flag buttons from the Visibility status 
toolbar.  
Only the cyan CONS remain visible. 
 
Cyan CONS show connectivity of more than two 
Faces and are usually present at T-junctions. If 
there are no T-junctions present, then usually 
cyan CONS imply the existence of multiply 
defined Faces. 
Zoom in to the area on the right as shown. 

 1 2 
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Activate back the “Double” and “Single” bounds. 
Activate also the “Shadow” and “Cross Hatches” 
buttons. 
 
 
The resolution is a bit coarse to clearly identify 
the problem. 
 

Activate the Auxiliaries>Fine 
function and left click once on 

the crosshatch of both Faces. 

 

The resolution is better. 
 
This is an area of overlapping Faces. 

 

 
To inquire, activate the 
Faces>Info function and click on 

one red CONS. 
 
 
ANSA highlights the whole Face. 
 
You can do the same for the other red CONS to 
see the overlap. 

 

Activate the CONS>Project 
function. 

 
 
 
 
 
 
Select with the left mouse button the CONS 
shown. 
 
 
Confirm with middle mouse button. 

Fine 
 
 

Info 
 
 

Project 
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Next select the Face to be trimmed, from its 
crosshatch. 
 
 
 
 
 
 
 
 
 
Confirm with middle mouse button. 

 

The Face is trimmed. 

 

Activate the Faces>Delete 
function and select the excess 

Face. 
 
Press Delete in the Faces Delete List window 

that appears.  

 

A gap remains. 
 
 

Activate the Faces>Topo 
function, select with a box 
selection the area shown on the 

left and confirm with the middle mouse button. 

 

Delete 
 
 

Topo 
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Activate the Hot Points>Delete function and use 
box selection to delete all the remaining 
unnecessary Hot Points.  

 

Finally zoom in to the area where cyan CONS 
are present. 
De-activate “Cross Hatches” visibility so as not 
to accidentally select a Face from its 
crosshatch. De-activate the “Shadow” mode 
also. 
 
To identify and correct the problem you will use 
the Faces>Delete function and its preview 
capabilities. 

Activate the Faces>Delete 
function. 

Select the Face from one cyan CONS as 
shown. 

 

The Faces Delete List preview window appears, 
indicating that 3 Faces are connected at that 
CONS. The first one (1 of 3) is highlighted. 
(! Note the order of preview may be different in 

your case). 
 
Press the KEEP 

button (or K in the 
keyboard) to keep this 
Face and proceed to 
the next one. 
 

 

 
The second Face (2 of 3) is then previewed. 
Again press the KEEP button (or K in the 

keyboard) to keep the Face. 

 

Delete 
 
 

Delete 
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Finally, the third Face is previewed. 
This Face must be deleted, as it is redundant. 

 
Press the DELETE button (or D in the 

keyboard) 
 

 

The Face is deleted. 
 
Only yellow CONS remain. 
 
The geometry is clean. 
 
Press the ESC key to exit the function. 
 

 

One last check by de-activating “Double” 
visibility flags leaves red CONS only at 
expected locations, i.e. free edges and 
openings. 

 

 
 Activate the “Shadow” and “Double” flag 
buttons. 
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At this point you can check the geometry of the 
model again for any remaining problematic 
areas. 
 
Click the “Checks” button and select 
“Geometry”. 

 
In the Checks Manager window that opens click 
Execute. 

ANSA checks the geometry of the model and 
finds no problematic areas. 
 
 

 

Next click the “Checks” button and select 
Penetration>Intersections. 

 
Click Execute in the Checks Manager window. 

 
ANSA checks for intersecting geometry and 
finds no errors. 
 
The geometry of the model is clean. 
 
Close the Checks Manager window. 
 
Save the file by selecting the “Save” option from 
the “File” menu. 
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At this stage, you could optionally start again 
from the beginning, reopening the IGES file, but 
this time prior to doing so, click on the “Settings” 
button 

 
and activate the Clean Geometry flag in the 

“Topology” options group found in the 
“Translators” section of the Settings window.  
Your Tolerances should be kept in Middle again. 
Several of the problems you previously fixed 
manually, can be solved automatically. 
 

In addition, you can use the Hot Points>Rm.Overl> [Visible] function by first clicking 
on “Hot Points” to bring the hidden menu forth as shown.  

 

 
 
This function automatically trims overlapping Faces, and will fix one of the two cyan CONS problem 
areas. An identical example of that case is the third picture on p.37. 
 

Rm.Overl. 
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 5.  Defeaturing 

 

Some small openings exist at the bottom flange 
of the part. You will remove these, as they are 
too small to be included in the mesh. 
 

Activate the CONS>Fill Hole 
function. 

The Fill Hole Parameters window opens. 
 
Select with the left mouse button the opening 
shown.  

 

 

 
 
 
 
The selected opening (red CONS perimeter) is 
highlighted. 
Alternatively you can enter a value of 20 in the 
“holes with diameter <” entry field and press the 
Select button. 

 

All the openings with an effective diameter 
smaller than the input value are selected 
automatically. 

Fill Hole 
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Press OK. 

 
All the selected openings are filled. 
 
Press ESC to exit the Fill Hole function. 

 

Move to the top of the part. 
 
Here there is a small non-uniform flange. 
 
Zoom to the area in the white circle as shown 
on the left. 

 

 
 
Activate the “Measure” function from the Utilities 
Toolbar. 
 
The Measure window opens, where by default 

the “Nodes” selection mode is active. 
 
Select with the left mouse button the two Hot 
points shown. 
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As long as a selection has been made, the 
possible available results are listed in the 
Measure window. 
 
The distance as shown on the screen and 
reported in the Text Window is less than 3mm. 

 

You will replace this flange all around with a 
constant height flange of 10mm. 
 
Close the Measure window. 
 
Click on “Faces” to bring the hidden menu forth. 

 
 

Activate the 
Faces>Flange>[Width] 
function. 
 

 

Select all the red CONS shown (in the direction 
of flange extension only) with the left mouse 
button.  
Confirm with the middle mouse button. 
 
The Flange Distance window appears. 
Type a value of 10 and activate the Delete Old 
Flange flag. 

 

Press OK. 

Flange 

Width 
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The Faces of the old flange are deleted and 
new Faces of the specified height are created. 
 
 
Note some remaining red CONS. 
 
 

 

Activate the Faces>Topo 
function. 

 
 
Make a box selection of the CONS as shown. 
 
 
 
Confirm with the middle mouse button. 

 

Topology is applied. 
 
 
The CONS are now yellow. 
 
 
 

Activate the Hot Points>Delete 
function. 

 
 
Make a box selection of the area shown. 

 

The unnecessary Hot Points are deleted. 

 

  

Topo 
 
 

Delete 
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Finally press the Faces>Orient 
function to assign a uniform 

orientation to all visible Faces. 

 

Press again the Orient button to flip the current 
orientation if necessary. 
 
 
 
 
 
 
 
 

 

Press F9 to fit all to the screen. 
 
 

 
The defeaturing process should now be 
complete. 
 
 
 
 
You will make some final checks. 
 

 

De-activate the “Shadow”, “Cross Hatches” and 
“Double” visibility flags. 
 
You should only see three closed paths of red 
CONS corresponding to the outer perimeter and 
two openings of the part. 
 
If not, correct the problems. 

 
Additionally, you can perform the 
“Checks>Geometry” and 
“Checks>Penetration>Intersections” 

operations and see that no errors are reported. 

Orient 
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Activate again the “Shadow” and “Double” flags. 
Note in case that there are Faces that fail the 
Shadow operation, the so called Unchecked 
Faces, then these Faces are reported on the 
Screen 

 
Using the Context Menu 
(right click menu) of the 

unchecked faces, these can be isolated on the 
screen in order to be corrected. 

Such Faces usually are thin 
needle shaped Faces or 
Faces that have bad Surface 
description. 
 
If in your case no 

Unchecked Faces are reported on the screen, 

then no such problems exist in your model. 
 

 

Press “All” from the Focus group to 
make all the Faces visible. 

The geometry defeaturing is completed. Save the file by selecting the “Save” option from the “File” 
menu. 
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 6.  Shell meshing – Uniform size mesh 

 

Switch to MESH menu. 

In MESH menu the Faces are now Macro Areas 
and the CONS are Perimeter Segments. The 
Hot Points are here displayed as white dots. 
Along the Perimeter Segments you can see 
magenta Perimeter nodes. These are placed 
initially according to the CONS Resolution 
settings. In this case the nodes are placed every 
20mm, except some regions where you have 
used the Fine function to change the Resolution 
locally. 

 

You will assign a uniform distance between 
Perimeter Nodes, or Element Length. 

Activate the Perimeters>Length 
function.  

Select all the Macro Areas with the left mouse 
button making a box selection. Confirm with the 
middle mouse button. 

The Length Parameters window opens. 

Type in a value of 10 in the Length field, leave 
the other fields empty (default values will be 
used) and press Enter. 

 

The new element length is applied to all the 
Perimeter Segments of the selected Macro 
Areas. 
 
(Note that although we started with a CONS 
Resolution length (and correspondingly Element 
Length) of 20mm, we will mesh the part with an 
element length of 10, so as to keep more 
details). 
 

Activate the Mesh Generation> 
Adv.Front function in order to 

mesh the Macros with the Advancing Front 
algorithm, which is recommended for uniform 
size meshes. 

 

Length 
 
 

Adv.Front 
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In the Options window, in the lower right corner 
of the screen, make sure the “Reconstruct” 
option is enabled so it will run right after the 
meshing algorithms in order to get a high quality 
mesh. For element type select “Tria”. 
Make a box selection of all the Macros and 
confirm with the middle mouse button. 
 
All the Macro Areas are meshed with the 
Advancing Front algorithm. 
The number of the visible elements is given in a 
text legend on the left (Note, the values may 
vary slightly). 
 

 

In order to check the quality of the generated 
Mesh, switch to “Hidden” view mode by 
pressing the corresponding button located in the 
Drawing styles toolbar at the bottom of the 
screen. 

 
Hidden mode displays all the violating elements 
according to the current Quality Criteria settings 
(these settings are accessed by pressing the 
F11 key). 
The number of the violating elements is 
reported in the legend as Off. They are also 
colored according to the type of violation (also 
explained in the legend). 
 
You can isolate the violating elements on the 
screen by right clicking on the “Off” word in the 
legend and selecting “Show only”. 
Select “All” from the focus toolbar to make all 
the elements visible again. 
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You will use some functions to manually 
improve the quality of the generated mesh. As it 
will be shown later on, these Off elements can 
be handled automatically. 

 
Activate the “Shadow” mode.  
 
 

Zoom in to the front of the part. Notice how the 
elements are squeezed in the small triangular 
shaped Macro Area. 
 

Activate the Macros>Join 
function ensuring that the Mesh 

option is set to “Erase” and the “Delete hot 
points” flag is de-activated in the options area in 
the lower right corner of the screen. Select with 
the left mouse button the two Perimeter 
Segments shown. 

 

 

The Perimeters are removed and the two 
Macros are joined to form a larger one. The 
mesh is of course erased. 
Note that if you join a Perimeter by mistake, you 
can retrieve it using the Macros>Release 
function, just picking it from the preview). 
 
Notice that some Hot Points are left over. 
 

Activate the Hot Points> Delete 
function and select them with 

the left mouse button making a box selection as 
shown here. 

 

The Hot Points are removed and the Perimeter 
Segments are connected into longer, more 
uniform Segments. The mesh of the neighboring 
Macro is also erased. 

 

Join 
 
 

Delete 
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Activate the 
Mesh Generation> 
Remesh>[Visible] 
function. 
 

The erased Macro Areas are remeshed with the 
same meshing algorithm, in this case the 
Advancing Front algorithm. 
 
As you can see every action that results in the 
modification of a Macro, leads to the erasure of 
its mesh. Then you have to use the function 
Mesh Generation>Remesh to remesh it. 

 

With the Join function is activated, activate the 
“Delete hot points” flag and set the Mesh option 
to “Remesh Macros” in the Options window in 

the lower right corner of the screen. 

 

This option will allow the automatic deletion of 
any remaining Hot  Points and the automatic 
remesh of the Macros after any Join operations. 
 
Move to the top round flange area. 

 

Notice here a Perimeter Segment that is too 
short to have even one Perimeter Node. 

Activate the Perimeters> 
Number function. 

Select with the left mouse button the small 
Perimeter Segment as shown and confirm with 
the middle mouse button. The Number window 
opens, where the current nodal number (0) is 
reported. 

In the Options window enable the Remesh 
Macros option so that the Macros are remeshed 
after each modification is made to the mesh and 

causes its erasure.  
 
Make sure that this 
option is from now 
on enabled on all 
those functions that 
support it. 
Type in the value 1 in 

the “New Number” entry field and press Enter. 

Remesh 

Visible 

Number 
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One nodal number is assigned to this Segment, 
which is now colored red, to indicate the nodal 
number has been specified explicitly and not via 
the element Length.  
 
While still in the Perimeters>Number function, 
right click on the three Perimeters shown on the 
left to assign the same nodal number of 1. 
 
Press ESC to exit the function. 
 

 

 
The mesh is better. 
 
 
 
 
 
Moving now to the round flange itself. 
 
Suppose you want to have two rows of 
elements along the flange. 

 

Activate again the Number function as above 
and activate the “Opposite” option in the 
Selection Assistant toolbar.  

 

 

Select the perimeter shown on the left with the 
left mouse button. ANSA automatically selects 
all the Perimeter Segments that are parallel to 
the selected Segment in a continuous path of 
Macro Areas. 

 

Confirm with the middle mouse button. 

 

Type in a value of 1 and press Enter to assign it 
to all the selected Segments. 
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However the automatic remeshing does not give 
the desired result. In this case the Advancing 
Front algorithm did not produce two rows of 
elements everywhere. 

 

Activate the 
Mesh 
Generation>Map>  
[Re-Generate] 
function. The Re-

Generate option means erase and mesh from 
new with the current algorithm and settings). 
 
Select with the left mouse button the Macros of 
the flange as shown, and confirm with the 
middle mouse button. 

 

ANSA erases the mesh and meshes with the 
MAP algorithm to produce the desired result. 
 
 
(Actually you will see in the more advanced 
tutorial that mesh treatment of flanges, holes, 
fillets etc. can be prescribed in ANSA in 
advance and applied automatically). 
 
Press ESC to exit the function. 

 

Move on to the top flange of the part. 
Notice how the elements are misaligned. 
Making a Cut along the symmetry plane of the 
part would improve the mesh. 
 

Activate the Macros>Proj.Cut 
function. Select the bottom Hot 

Point and the opposite top Perimeter as shown 
on the left. 
 
 
 

Map 

Re-Generate 

1 

2 

Proj.Cut 
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A new Hot Point is created at the projection 
location and a Cut between the two is made. 
 
ANSA remeshes automatically. 
 
 
While still in the Proj.Cut function select the top 
Perimeter, as shown, in order to continue from 
the last position with the cut operation further 
upwards.  

 

 
ANSA projects, cuts and remeshes. 
 
The last Hot Point remains highlighted for 
further cut operations, but in this case press 
ESC to exit the function.   

 

Finally use the Perimeters> 
Number function to place one 

node in the short vertical Perimeter as shown. 
Make sure to activate the entities selection 
mode in the Selection Assistant toolbar. 

 
 
Confirm with the middle mouse button. 

 
Enter the value 1 and press Enter. 

Number 
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ANSA applies the new nodal number and 
remeshes. 
 
 
 
Still you can improve the mesh of the fillet 
region, by meshing it with a different algorithm. 
 

 

 
Activate the function 
Mesh Generation> 
Map>[Re-Generate]. 
 

 
Select the Macro Areas with the left mouse 
button as shown. You can de-select with the 
right mouse button if required. 
 
 
Confirm with the middle mouse button. 

 

ANSA erases the current mesh and meshes 
from new with the MAP algorithm. 
 
 
The resulting mesh better represents the curved 
fillet. 

 

Move to the area of the round protrusion. 
 
Notice how many small elements are confined 
in narrow Macro Areas. 
 

Use the Macros>Join function 
to join the Segments, and 

create larger Macros. 

Map 

Re-Generate 

Join 
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Then activate the Hot Points> 
Delete function and select with 

box selection the area shown.  

 

Optionally you can use the 
Perimeters>Number function 

and assign nodal numbers, 1 and 6 nodes 
respectively to the two remaining Segments as 
shown.  

 

 

 

Press F9 to fit all in the screen. 
 
 

 
 
 

Join these two Segments that 
interrupt the mesh of the flange. 

 

Delete 
 

Number 
 

Join 
 

1 

2 
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Switch to the “Hidden” mode to check the 
quality of the mesh.  

 

Note that the number of the Off elements has 
dropped. 

 

Up to this point, for training reasons, you have 
used various functions in order to manually 
improve the quality of the mesh. ANSA is able to 
improve the mesh quality automatically in an 
efficient and easy way. 

This is achieved via the Shell Mesh>Reshape> 
[Advanced] function which automatically 
performs local Perimeter Join and mesh 
reconstruction. 

 

 

Activate the “Shadow” mode again. 

Activate the Shell 
Mesh>Reshape> 
[Advanced] function.  

 

In the Advanced Selection window that opens 

keep the “Violating” option and “Expand level” 
value 2. 

 

Press OK and then confirm with the middle 

mouse button. 

 

ANSA performs local Perimeter Join operations 
and Reconstruction to fix the problems. 

Switch to “Hidden” mode again and see that no 
Off elements are reported in the legend. 

 

 

Reshape. 

Advanced 
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Activate again the “Shadow” mode. 

 

The uniform mesh is complete.  

Note that the number of elements displayed in 
the legend may differ depending on the actions 
that were taken during Macro manipulation. 
 
 
(You can output the shell mesh in any of the 
available output formats, through File>Output). 

 

 

 

 

 

You can de-activate the 
visibility flag buttons for 
“Perims” and “Hot Points” 

(under the Perimeters Points flag) in order to 
view the mesh better. 

  
Notice that in case the “Perimeter” flag is 
deactivated the “Perimeters Points” get also not 
visible. 
 
Activate the visibility flags for “Perims” and “Hot 
Points” again. 
 
Save your work by selecting the File>Save 
option. 
 

 

  

D
i
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7. Shell meshing – Variable size mesh 

 

Now you will create a variable size, curvature 
dependent mesh.  

 

Activate the Mesh 
Generation>Erase> 
[Visible] function to erase 
the uniform mesh. 

 

Before starting a new mesh, it is important to 
restore the model to its original state before any 
joining or perimeter modification operations.   

ANSA can automatically restore the model to its 
initial state before the manual join actions were 
performed, following the steps described below: 

 

Activate the Macros>Join 
function and make a box 

selection of all the Macros as shown on the left. 

 

 

All the Macros belonging to the same PID are 
joined. 

 
Join 

 

Erase 

Visible 
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Activate the Macros>Release 
function and make a box 

selection again of all the Macros as shown. 

 

! Note that the Perimeters between Macro areas 

that have the same Surface (underlying CAD 
description) and have been previously joined, 
cannot be retrieved with the Release function. 

This is the case for the two Perimeters that were 
manually joined at the beginning of the Uniform 
mesh chapter on page 50. 

 

 

 

Finally, activate the 
Perimeters>Init function to reset 

the Number of nodal points and the nodal 
distribution of the selected Perimeters and make 
a box selection as shown. 

 

The selected perimeters are highlighted. 

 

Confirm with the middle mouse button. 

 

Activate the 
Perimeters>Spacing> 
[Auto CFD] function. 

 

In the CFD Spacing Parameters window that 
opens enter the values as shown on the left.   

 

Note that the resulting mesh will consist of 
elements with a length ranging from 2mm to 
10mm. 

 

No sharp edges are present in this model. 
However you can activate the convex and 
convace sharp edges length flags. These values 
are used to set the element length on 
Perimeters between Macros that form a sharp 
angle. It is advisable in general to refine such 
edges because of their importance to the flow. 

The Perimeters>Spacing>[Auto CFD] function 
will automatically apply a curvature dependend 
refinement to all visible Perimeters. 

 

Press OK. 

Release 
  

Init 
  

Spacing 

Auto CFD 
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Prior to meshing, ANSA can perform an 
automatic Perimeter Joining and Macro 
simplification procedure, resulting eventually in 
a better mesh quality. 

Activate the Macros>Simplify 
function. 

Keep the default options in the Simplify window 
that opens and click Run. 

 

ANSA selects the Perimeters to be joined so 
there is no need to make any manual 
selections. 

 

However, it is possible to manually add more 
Perimeters to be joined by selecting them with 
the left mouse button. 

 

Select the four Perimeters as shown on the left. 

 

Click OK. 

 

As after the Simplify 
function the Perimeters 
have been modified, the 
Perimeters>Spacing> 

[Auto CFD] function has to be re-applied. 

 

Activate the function and in the CFD Spacing 
Parameters window press OK keeping the 

same options as before. 

 

Now that the perimeters have been assigned 
the curvature dependend refinement, the mesh 
can be generated. 

 

Simplify 
 

Spacing 

Auto CFD 
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Activate the Mesh 
Generation>CFD> 
[Visible] function. 

 

ANSA meshes the Macros with a variable size, 
curvature dependent mesh. 

Rotate the part to observe the mesh refinement. 

 

 

Switch to “Hidden” mode to check the quality of 
the mesh. No Off elements should be reported 
in the legend.  

 

However if some Off elemetns exist, use the 
Shell Mesh>Reshape> [Advanced] function to 
fix the problematic areas. 

 

 

Enable back the “Shadow” mode. 

 

The tutorial is completed. 
 

Save the file from File>Save. 

Quit ANSA from File>Quit. 

 

 

 

CFD 

Visible 
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 8.  Conclusion 

 

 
 
 

In this tutorial you have followed all the basic steps to cleanup the geometry of a part, remove some 
small details and mesh it with shell elements, initially applying a uniform mesh and then a variable 
size, curvature dependent mesh. Not all capabilities were demonstrated. Refer also to the  
ANSA for CFD Quick Start Guide.pdf document and to the On-Line Help for the functionality of 
ANSA and detailed description of functions and procedures. 
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